Mailingliste, eller mailing-liste hører til det digitale miljø - konkret er mailinglister en speciel e-mail-service. Konceptet er generelt beskrevet et mail-system baseret på en centralt lokaliseret liste over kontaktadresser, det vil sige mailadresser. Funktionelt sender den enkelte bruger mail til mailinglisten, eksempelvis adresseret til [email protected], og mailserveren sender så brugerens mail videre til de der har tilmeldt sig denne mailingliste. Det danske ord postliste bliver nogen gange brugt med lignende betydning.

Historie Mailinglister har udviklet sig til at være ret sofistikerede forums for gruppe-kommunikation og samarbejde;(..) - frit oversat efter .

I en tidlig RFC beskrives nogle problematikker i datidens Arpanet. Her forekommer mailing-list som betegnelse for listen af modtagere i en e-mail . På det tidspunkt svarede en mailingliste så nogenlunde til en mængde adresser samlet i et adressekartotek i den personlige e-mail-klient.

Praksis og teknik Alle har deres præferencer, fx rollespil, politik eller programmering - mailinglister er her blevet brugt til at samle tropperne (i overført betydning) og tilvejebringe en hurtig og teknisk effektiv kommunikationsform for gruppe-fællesskaber. Specielt karakteristisk er mailinglistens fælleshed: Alle sender til alle og alle modtager fra alle, om det så er eksperten og novicen eller formanden og den frivillige.

Teknisk beskrevet findes mailinglisten på en mailserver, hvor serverens MTA, ex. Courier konfigureres til at kunne formidle og arkivere en mailingliste. Det er også udbredt at præsentere mailinglisten via http i et html-format, så mailinglisten faktisk bliver til en hjemmeside der kan læses med en browser. Courier kan konfigureres til at producere mailinglister, men også særskilte program-distributioner såsom Listserv, Mailman eller Majordomo kan tilvejebringe sådan en funktion. Discourse, der er et forholdsvist nyt CMS-produkt omfatter også en mailingliste .

Som det fremgår af navnet er mailinglister baseret på e-mails. I det perspektiv er tekst-formatet i teknisk overensstemmelse med RFC-822 eller RFC-2822 og med nogle definerende udvidelser, specielt i overensstemmelse med RFC-2369 . Som transport-mekanisme er mailinglister helt identisk med e-mails: I overensstemmelse med smtp-protokollen (RFC-5321) som en mailto: URL, eller for webmail via cgi som en almindelig http: URL. Det findes beskrevet ved eksempler hos . I modsætning til newsgroups er der ikke en skematiseret forventning om den enkelte mails levetid. Mailingliste-arkiver er almindelige og præsenteres i html, se fx lists.w3.org/Archives/Public/public-html/.

Der findes både danske og internationale service-udbydere af mailinglister. Derudover kan mailinglisten produceres ved hjælp fra konsulent-bureauer eller som et internt projekt. Google Groups er en alment tilgængelig mulighed for her og nu at oprette noget der minder om mailinglister .

Tabularisk oversigt Internetfora og teknisk beskrivelse Fil:Wwwfora.table upper.png

Tabelbeskrivelse: Type Almindeligt navn på en webteknologi. Brugerflade Almindeligt navn på sidste led i den software-kæde der formidler tekst-typen. Oversigt Sortering af tekst-samlinger i den givne type. Hierarki Fastlæggelsen af skrive-rettighed på liste-form. Tekst Skriveret; gængs navn på tekst-element. (1) titel, frase eller enkel sætning uden følgetekst; (2) tema, ekspansiv tematisering inklusiv overskrift; (3) respons, kommentar. Fil:Wwwfora.table lower.png

Tabelbeskrivelse: Generelt Tabellen viser nogle typiske eksempler. CMS produkter som Typo3 (php) og Discourse (Ruby) følger ikke tabellens firkantede skematisering, blandt andet blog-programmet MovableType (Perl) fungerer i samspænd med en MTA og udviklingen af mailklienter såsom Icedove (XUL) præsenterer en brugerflade der er baseret på W3C specifikationerne. RFC publiceres af IETF. De nævnte program-pakker er under GNU, OpenSource eller lignende licens. Program-pakker er skrevet med kursiv i tabellen. Programtype Runtime, programmeringssprog samt Server, gængs navn på den netværks-orienterede type. Administrativ scripting af server-programmer samt spam-filtre er varieret og ikke afbildet her. Tekstformat De mest generelle og relevante specifikationer for tekstformatet af blogindlæg, forumposter og mails. Bemærk! De anførte RFC's forhindrer ikke principielt muligheden for at producere html, xml etc. via filter-programmer. Transport Bemærk! Webmail benytter http og præsenterer eksempelvis html. Se også (meget lang liste udeladt) Kilder Program-beskrivelser fra Debian Squeeze (binary,stable) Synaptic Package Manager samt

Se også Det digitale miljø, baggrund: Internet, Email, Usenet En tidlig ikke-standard: PLATO Apropos mailinglister: Åbne postlister, Nyhedsbrev

Eksterne links Maillist arkiver hos W3C Om LISTSERV, en tidlig maillist management software.

Kilder

Kategori:Elektronisk post