DomainKeys Identified Mail(DKIM)とは、電子メールの送信ドメインを認証する技術である。DKIMは、署名するMail transfer agent(MTA)から検証するMTAまで、ほぼエンド・ツー・エンドの完全性を提供する。多くの場合、署名するMTAが発信者に代わりDKIM-Signatureヘッダを追加し、また検証するMTAがDNSを通じて発信者の公開鍵を検索することで、受信者に代わり署名の正当性を立証する。
DomainKeysの仕様は、DKIMを作るためにIdentified Internet Mail(IIM)の特徴を採用した。DomainKeysとIIMを併せた仕様は、IETF標準化提案(Proposed Standard)に向けて仕様を導いたIETFワーキング・グループのための基礎である。
一般的な動作方法について、詳しくはDomainKeysを参照。DKIMはあらゆる点でDomainKeysの動作に極めてよく似ている。
関連項目 送信ドメイン認証 DomainKeys Sender Policy Framework (SPF) Sender Signing Policy (SSP) S/MIME OpenPGP フィードバックループ
外部リンク dkim.jp (Japan DKIM Working Group) Domain Keys Identified Mail (DKIM) IETF DKIM working group (started 2006) RFC 4871 - The DKIM Base Specification RFC 5672 - RFC 4871 DomainKeys Identified Mail (DKIM) Signatures -- Update RFC 6376 - DomainKeys Identified Mail (DKIM) Signatures