Hypertext Transfer Protocol (HTTP) er ein nettverksprotokoll som blir brukt for å overføre det meste av informasjon på verdsveven. HTTP styrer kommunikasjonen mellom ein HTTP-klient, typisk ein nettlesar og ein HTTP-tenar. Dette blir gjort ved at klienten sender ein førespurnad til tenaren, og denne vil da gje ei statusline, som «HTTP/1.1 200 OK», og si eiga melding. Meldinga inneheld typisk det som blei spurt om, som ei viss datafil, men kan også vera ei feilmelding eller annan informasjon.
Soge
Utviklinga av HTTP vart leia av World Wide Web Consortium og ulike arbeidsgrupper i Internet Engineering Task Force, som resulterte i ei rekkje sokalla RFC. Den viktigaste av desse var RFC 2068 frå 1997, som definerer HTTP/1.1. Han blei oppdatert av RFC 2616 i 1999, og av RFC 7230 i 2014.
Kjelder
Denne artikkelen bygger på «Hypertext Transfer Protocol» frå , den 25. februar 2020.
Kategori:W3C-standardar Kategori:Opne standardar Kategori:Applikasjonslagprotokollar